Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000117Core InformPropertiespublic2010-06-24 03:312010-07-01 23:07
Assigned Tograham 
Platformx86OSWindowsOS VersionXP
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000117: A room is not accepted as property if it is created through a direction
DescriptionIf a room is created with "R1 is [direction] of R2", it won't be accepted as a value property.

If the room is created with "R1 is a room. It is [direction] of R2.", it can be used normally.

Additionally, if you assign R1 to a region, it will be accepted as property even if it is created through direction.
Minimal Source Text To Reproduce
R1 is east of R2.

A person has a room called homeroom.

John is a man.
Jane is a woman.

The homeroom of John is R1.
The homeroom of Jane is R2.
Additional Informationto make it compile:
either change to:

R1 is a room. It is east of R2.
R2 is a room.

or add:

Space is a region. R1 and R2 are in Space.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
emshort (administrator)
2010-06-24 08:48

These errors produce a problem message of the form

Problem. In the sentence 'The homeroom of John is R1' , it looks as if you intend 'The homeroom of John is R1' to be asserting something, but that tries to set the value of the 'homeroom' property to an object - which must be wrong because this property has to be a room.

Suspect the problem is that type-checking occurs for homeroom properties before we have definitely decided that R1 and R2 are rooms: based purely on the direction assertion, they could also be doors.

The statement about regions resolves this ambiguity.
graham (administrator)
2010-06-30 15:46


- Issue History
Date Modified Username Field Change
2010-06-24 03:31 i-k New Issue
2010-06-24 08:48 emshort Note Added: 0000148
2010-06-24 08:48 emshort Status new => confirmed
2010-06-30 15:46 graham Note Added: 0000198
2010-06-30 15:46 graham Status confirmed => resolved
2010-06-30 15:46 graham Resolution open => fixed
2010-06-30 15:46 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker