Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001169Core InformSpacing and printingpublic2013-12-29 10:212014-05-07 07:33
Reporterherrdu 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityhave not tried
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001169: relations command generates programming error with printed name property on assembled object
DescriptionIf there is a relation between an assembled object whose parent has a printed name property, executing the relations command produces a programming error message. This only occurs when the assembled object is in the left part of the relation. Without the printed name property there is not an error.

>[1] relations
Underlying relates various garment-elements to various garment-elements with fast route-finding:
  
[** Programming error: object#46 (object number 46) has no property cap_short_name to read **]
's body-part >=> the suit
  The suit >=> your friend's body-part
Minimal Source Text To Reproduce
Example is a room.

A garment-element is a kind of thing.  A body-part is a kind of garment-element. One body-part is part 
of every person.

Underlying relates various garment-elements to various garment-elements with fast route-finding. The 
verb to underlie (it underlies, they underlie, it is underlying, it is underlaid) implies the underlying 
relation. The verb to be under implies the underlying relation.

John is a person.  The printed name is "your friend".

A suit is a garment-element. John's body-part is under the suit.  The suit is under  John's body-part.


test me with "relations".
Additional InformationThis may be a duplicate of 1128
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
duplicate of 0001128closedgraham "[The X]" on proper-named assembly with owning object having a printed name property results in "Programming error" 

-  Notes
(0002223)
zarf (developer)
2013-12-29 12:14

Yes, it's a duplicate. The "relations" command displays with this code:

print " ", (The) obj1;
print " >=> ";
print (the) obj2, "^";

So the left-hand side takes the capitalization path, and that's what you're seeing.

I've verified that in 1128, if you set up a relation between the muzzle and another object, the "relations" command shows the same symptom.
(0002224)
zarf (developer)
2013-12-29 12:16

Confirmed too.
(0002404)
graham (administrator)
2014-01-28 13:06

Yes indeed: duplicate (but welcome, all the same).

- Issue History
Date Modified Username Field Change
2013-12-29 10:21 herrdu New Issue
2013-12-29 12:14 zarf Note Added: 0002223
2013-12-29 12:15 zarf Relationship added duplicate of 0001128
2013-12-29 12:16 zarf Note Added: 0002224
2013-12-29 12:16 zarf Status new => confirmed
2014-01-28 13:06 graham Note Added: 0002404
2014-01-28 13:06 graham Status confirmed => resolved
2014-01-28 13:06 graham Resolution open => fixed
2014-01-28 13:06 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker