Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001164Core InformModel worldpublic2013-12-26 04:452014-05-07 07:33
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001164: NPCs cannot touch doors or their parts when on the other side of them from the player
DescriptionIf an NPC is on the other side of a door from the player, then the basic accessibility rule will rule that the NPC cannot touch the door (though the player would be able to, were she in that room).
Minimal Source Text To Reproduce
The Reliquary is a room. The wooden door is a door.  The wooden door is inside from the Reliquary 
and outside from the Crypt.
The ghost is a person in the Reliquary.

Instead of singing: try the ghost closing the wooden door.

Every turn: say "The ghost can[if the ghost cannot touch the wooden door]not[end if] touch the wooden 
door."

The handle is part of the wooden door. Instead of an actor turning the handle: try the person asked opening 
the wooden door.

Instead of jumping: try the ghost turning the handle.

Test me with "actions/z/in/sing/jump".
Additional InformationBecause of bug 886, the NPC will still be able to interact with the door; but she will be unable to interact with its parts. (That is, if the action involved requires a thing rather than a visible thing; the NPC will be able to examine the handle.)
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000886closedgraham In-scope doors are always reachable for most actions, including entering. 

-  Notes
(0002205)
EmacsUser (manager)
2013-12-26 09:30

Ah, good point about the handle. I believe you're right that this is a separate case from 0000886.
(0002494)
graham (administrator)
2014-02-14 13:56

Yes, I've improved this.

- Issue History
Date Modified Username Field Change
2013-12-26 04:45 mattweiner New Issue
2013-12-26 09:30 EmacsUser Note Added: 0002205
2013-12-26 09:30 EmacsUser Status new => confirmed
2013-12-26 09:30 EmacsUser Relationship added related to 0000886
2014-02-14 13:56 graham Note Added: 0002494
2014-02-14 13:56 graham Status confirmed => resolved
2014-02-14 13:56 graham Resolution open => fixed
2014-02-14 13:56 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker