Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001154Core InformRelationspublic2013-12-04 17:062014-05-07 07:34
ReporterPO8 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version 
Target VersionFixed in Version6L02 
Summary0001154: Compiler hangs on attempt to add relation as attribute.
DescriptionAn attempt to add a relation as an attribute of a kind causes the compiler to hang "Drawing Inferences".
Minimal Source Text To Reproduce
"Bug" by "Bart Massey"

The Bug Room is a room.

A thing has a relation between numbers and numbers called the tag.
Additional InformationThe bug seems pretty robust.
TagsNo tags attached.
Effect(critical) Compiler hangs
Attached Files

- Relationships
related to 0000582closedgraham Segmentation fault when the text ``relates to'' appears in a declarative context 

-  Notes
(0002169)
zarf (developer)
2013-12-04 17:18

Confirmed. On MacOS, it's a segfault.

This is almost certainly a duplicate of http://inform7.com/mantis/view.php?id=582 [^] . Graham can verify that and close this as a duplicate if it is.
(0002170)
zarf (developer)
2013-12-04 17:19

Stack trace, which is slightly different from 582 but winds up in the same place:

0 ni 0x000087a6 Text__Vocabulary__get_kind + 6
1 ni 0x000a2991 Parser__SParser__SP_kind + 977
2 ni 0x000a2c86 Kinds__parse + 38
3 ni 0x00122ca4 recursively_call_properties + 84
4 ni 0x00122b16 Parser__Assertions__recursively_declare_properties + 182
5 ni 0x001341b2 make_assertion_recursive_inner + 4754
6 ni 0x00135d75 Parser__Assertions__make_assertion_recursive + 53
7 ni 0x00136e74 Parser__Assertions__make_assertion + 84
8 ni 0x00137e19 to_be + 57
9 ni 0x000a3673 Parser__Assertions__traverse + 419
10 ni 0x0012b932 Config__Template__interpret + 9346
11 ni 0x001314bc main + 636
12 ni 0x00002019 _start + 208
13 ni 0x00001f48 start + 40
(0002245)
graham (administrator)
2014-01-04 10:35

That should be "a relation of numbers", or "a relation of numbers to numbers", to do what was intended, so this was not exactly a duplicate of 0000582, only mostly so. Both fixed, anyway.

- Issue History
Date Modified Username Field Change
2013-12-04 17:06 PO8 New Issue
2013-12-04 17:18 zarf Note Added: 0002169
2013-12-04 17:18 zarf Status new => confirmed
2013-12-04 17:19 zarf Note Added: 0002170
2013-12-04 17:19 zarf Relationship added related to 0000582
2014-01-04 10:35 graham Note Added: 0002245
2014-01-04 10:35 graham Status confirmed => resolved
2014-01-04 10:35 graham Resolution open => fixed
2014-01-04 10:35 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker