Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000115Documentation, Examples, and Web SiteWriting with Informpublic2010-06-23 22:142010-10-29 09:23
ReporterRon Newcomb 
Assigned Tograham 
PlatformPPCOSMac OS XOS Version10.4
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000115: request small clarification for "unindexed" word
DescriptionThe last paragraph of 25.9. "Extensions in the Index" begins:

"Finally, any phrase or variable defined in a section whose name ends in the word "unindexed" will be omitted from the Phrasebook or Contents index respectively."

I request a clarification that by "section" it does not mean all headings such as "chapter" or "book", but just "section". Perhaps it's my mistake as I think of those things as "section headings" regardless the word they begin with, but I also feel it surprising that just one kind of heading was singled out for the "unindexed" feature. For example, I don't think either the heading-replacement from 25.8 or the "not for release" feature from 2.9 is similarly restricted to "section".

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
Ron Newcomb (reporter)
2010-06-29 15:07

(Or, if unindexed does work on chapter headings (and larger), it only treats "chapter" as a synonym for "section", not as a container for multiple sections, as the "not for release" feature does.

I sometimes seem to get mixed results, but it could be my perception.)
emshort (administrator)
2010-08-29 07:04

This is strange enough that I don't want to just confirm it in the documentation -- is "unindexed" really intended to work this way?
EmacsUser (manager)
2010-08-31 13:21
edited on: 2010-09-01 10:02

I can confirm that ``unindexed'' has no effect on headings that have subheadings, and that it makes no difference whether the heading is for a section, a chapter, or something larger. Therefore the compiler cannot be justified by a literal reading of the documentation.

Whether the behavior is a bug in the compiler or an undocumented restriction, I also do not know, so I'm leaving this in its current category for now.

Ron Newcomb (reporter)
2010-09-07 13:25
edited on: 2010-09-07 13:26

Small target test on 6E72 Windows:

chapter 1 - stuff unindexed

To foo: do nothing.

section 1 - possibly?

To lorem: do nothing.

section 1 - more unindexed

To bar: do nothing.


Lorem appears in the phrasebook, but the other two don't. So "unindexed" works for headings other than just Section -- foo is hidden -- but when used on a larger heading, it doesn't work on the headings within -- lorem is NOT hidden, despite being in a section that is within an unindexed chapter.

I get identical results changing "chapter" to part, volume, or book.

This bug just asks that the documentation be a little clearer on this behavior. The heading property not applying to its subdivisions is misleading, as is the documentation stating it is for sections only.

graham (administrator)
2010-09-29 02:32

I've duly clarified this. Some day we shall probably have to revisit the question of giving extensions private namespaces, in effect, and make this rather clumsy technicality redundant.

- Issue History
Date Modified Username Field Change
2010-06-23 22:14 Ron Newcomb New Issue
2010-06-23 22:41 jmcgrew Status new => confirmed
2010-06-29 15:07 Ron Newcomb Note Added: 0000178
2010-07-02 02:10 jmcgrew Product Version => 6E59
2010-08-29 07:03 emshort Assigned To => graham
2010-08-29 07:03 emshort Status confirmed => assigned
2010-08-29 07:04 emshort Note Added: 0000453
2010-08-29 07:04 emshort Status assigned => feedback
2010-08-31 13:21 EmacsUser Note Added: 0000471
2010-08-31 13:21 EmacsUser Status feedback => confirmed
2010-09-01 08:11 emshort Note Added: 0000480
2010-09-01 08:12 emshort Note Deleted: 0000480
2010-09-01 10:02 EmacsUser Note Edited: 0000471 View Revisions
2010-09-07 13:25 Ron Newcomb Note Added: 0000526
2010-09-07 13:26 Ron Newcomb Note Edited: 0000526 View Revisions
2010-09-29 02:32 graham Note Added: 0000614
2010-09-29 02:32 graham Status confirmed => resolved
2010-09-29 02:32 graham Resolution open => fixed
2010-10-29 09:23 jmcgrew Fixed in Version => 6F95
2010-10-29 09:23 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker