Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001141Core InformRules and rulebookspublic2013-10-17 07:402014-05-07 07:33
ReporterFuchsia tude 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001141: Naming a rule without "the", error message blames when/while clause
DescriptionNormally in I7, articles can be omitted without incident. "The" is required, however, in the naming of a rule. This is actually mentioned in passing in WI 18.3, but this might be more strongly emphasized.

In any case, when a rule with a "when" clause is named without using "the", NI incorrectly pins the blame on that clause.


Problem. You wrote 'Every turn when true is true (this is a ridiculous rule)' : but I don't understand the 'when/while' clause, which should name activities or conditions.
 
Minimal Source Text To Reproduce
There is room.

Every turn when true is true (this is a ridiculous rule): say "True."
Additional InformationAlso, if you omit the when clause, NI gets even more confused:

Problem. You wrote 'Every turn (this is a ridiculous rule)' , which seems to introduce a rule taking effect only '(this is a ridiculous rule)'. But this does not look like an action, since there is no sign of a participle ending '-ing' (as in 'taking the brick', say) - which makes me think I have badly misunderstood what you intended.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships
related to 0001139closedgraham "Named" rule missing a name breaks NI 
has duplicate 0000920closedgraham Unhelpful error messages when "the" is left out when naming a rule. 

-  Notes
(0002143)
zarf (developer)
2013-10-17 11:05

Confirmed.

Not identical to bug 1139 (where the code has the pattern "(this is the" but is missing stuff after it). But obviously in the same vicinity.

- Issue History
Date Modified Username Field Change
2013-10-17 07:40 Fuchsia tude New Issue
2013-10-17 10:59 zarf Relationship added related to 0001139
2013-10-17 11:05 zarf Note Added: 0002143
2013-10-17 11:05 zarf Status new => confirmed
2014-01-25 02:24 graham Status confirmed => resolved
2014-01-25 02:24 graham Resolution open => fixed
2014-01-25 02:24 graham Assigned To => graham
2014-01-26 19:13 EmacsUser Relationship added has duplicate 0000920
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker