Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001134Core InformUnderstandingpublic2013-09-20 10:522014-05-07 07:33
Reporterzarf 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001134: Disambiguation does not always exempt "person, foo" commands
DescriptionIf you reply to a disambiguation question with a new command, the parser aborts disambiguation and parses it normally. What is "a new command"? Any line starting with a verb, or containing a comma. The sample below demonstrates this, working correctly:

>get toy
Which do you mean, the red toy or the blue toy?
>jump
You jump on the spot, fruitlessly.
>get toy
Which do you mean, the red toy or the blue toy?
>frog, jump
The frog has better things to do.

However, this does not work in all cases:

>get
What do you want to get?
>jump
You jump on the spot, fruitlessly.
>get
What do you want to get?
>frog, jump
You can't see any such thing.

The last line fails to notice the comma, and proceeds to disambiguation ("get frog, jump" -> no such thing).

Another difference: "get toy" disambig does not treat the verbs "long", "short" as verbs (because they're so common as adjectives). "get" disambig is missing this special case.

>get toy
Which do you mean, the red toy or the blue toy?
>long
You can't see any such thing.

>get
What do you want to get?
>long
Test Case is now in its "verbose" mode, which always gives long descriptions of locations (even if you've been there before).

These errors are because NounDomain() has two spots for grabbing a disambig line: after .WhichOne and after .Incomplete. The second spot is missing some checks.

Minimal Source Text To Reproduce
The Kitchen is a room.

The frog is a person in the Kitchen.
The red toy is in the Kitchen.
The blue toy is in the Kitchen.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Filespatch file icon 1134.patch [^] (1,058 bytes) 2013-09-20 10:54 [Show Content]

- Relationships

-  Notes
(0002127)
zarf (developer)
2013-09-20 10:55

The attached patch (to Parser.i6t) fixes this, as far as I can tell.
(0002569)
graham (administrator)
2014-03-16 13:38

I've adopted the patch, which looks right to me; thanks.

- Issue History
Date Modified Username Field Change
2013-09-20 10:52 zarf New Issue
2013-09-20 10:54 zarf File Added: 1134.patch
2013-09-20 10:55 zarf Note Added: 0002127
2013-09-26 13:13 EmacsUser Status new => confirmed
2014-03-16 13:38 graham Note Added: 0002569
2014-03-16 13:38 graham Status confirmed => resolved
2014-03-16 13:38 graham Resolution open => fixed
2014-03-16 13:38 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker