Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001115Core InformKinds and type checkingpublic2013-05-21 06:522014-05-07 07:33
Reporterjjyy97 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001115: Naming a property after an existing kind causes the standard rules to produce errors.
DescriptionWhen naming a property of any object after another existing kind, all of the source that defined or utilized that kind produces an error, including in the standard rules.
Minimal Source Text To Reproduce
There is a room.
A person has a number called the direction.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships
related to 0000517closedgraham A kind "has a number" causes problems with the standard rules 

-  Notes
(0002057)
zarf (developer)
2013-05-21 11:23

Confirmed.
(0002058)
zarf (developer)
2013-05-21 11:24

This may be a duplicate of bug 517 ("A person has a number.") Someone will have to test whether the fix for 517 resolves this one.
(0002059)
NYKevin (reporter)
2013-05-21 11:57

@zarf: Reading Graham's comment, it sounds like all he did was add a special case to ban "a foo has a number/text". I don't see how that would affect this bug at all.
(0002062)
zarf (developer)
2013-05-21 21:14

Maybe he did something more general. That's why someone should test it.
(0002063)
EmacsUser (manager)
2013-05-23 10:08

I've adjusted the source so that the property's name and kind's name differ; otherwise it falls afoul of 0000435.
(0002353)
graham (administrator)
2014-01-25 05:01

There is now rather clearer reporting on this problem.

- Issue History
Date Modified Username Field Change
2013-05-21 06:52 jjyy97 New Issue
2013-05-21 11:23 zarf Note Added: 0002057
2013-05-21 11:23 zarf Status new => confirmed
2013-05-21 11:23 zarf Relationship added related to 0000517
2013-05-21 11:24 zarf Note Added: 0002058
2013-05-21 11:57 NYKevin Note Added: 0002059
2013-05-21 21:14 zarf Note Added: 0002062
2013-05-23 10:08 EmacsUser Note Added: 0002063
2013-05-23 10:08 EmacsUser Steps to Reproduce Updated View Revisions
2014-01-25 05:01 graham Note Added: 0002353
2014-01-25 05:01 graham Status confirmed => resolved
2014-01-25 05:01 graham Resolution open => fixed
2014-01-25 05:01 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker