Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000111Core InformPhrases and functional programmingpublic2010-06-23 17:462010-07-01 23:07
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.4
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000111: Wording descriptions of phrase arguments with ``that is'' leads to an ICE
DescriptionIn the source, rather than just ``four'' I've written ``a number that is four.'' The compiler reacts by giving this message:

An internal error has occurred: made null as atomic Types__KOVs__base_object. The current sentence is 'To consider (X - a number that is 4)' ; the error was detected at line 129 of "Chapter 15/Kinds of Value.w". This should never happen, and I am now halting in abject failure.
What has happened here is that one of the checks Inform carries out internally, to see if it is working properly, has failed. There must be a bug in this copy of Inform. It may be worth checking whether you have the current, up-to-date version. If so, please report this problem via www.inform7.com/bugs.

 As for fixing your source text to avoid this bug, the last thing you changed is probably the cause, if there is a simple cause. Your source text might in fact be wrong, and the problem might be occurring because Inform has failed to find a good way to say so. But even if your source text looks correct, there are probably rephrasings which would achieve the same effect.
Minimal Source Text To Reproduce
There is a room.
To consider (X - a number that is four): say "Four."
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0000180)
graham (administrator)
2010-06-29 15:27

An obscure inability to determine the kind of the free variable in "number which is 4". Fixed.

- Issue History
Date Modified Username Field Change
2010-06-23 17:46 EmacsUser New Issue
2010-06-23 17:59 jmcgrew Status new => confirmed
2010-06-23 17:59 jmcgrew Product Version => 6E59
2010-06-29 15:27 graham Note Added: 0000180
2010-06-29 15:27 graham Status confirmed => resolved
2010-06-29 15:27 graham Resolution open => fixed
2010-06-29 15:27 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker