Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001107Core InformKinds and type checkingpublic2013-04-19 20:512014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001107: Type violation caused by a calling in a failed condition
DescriptionThe attached source never assigns to quux—it should supply the default value when the condition fails.
Minimal Source Text To Reproduce
There is a room.
Foo is a kind of value.  The foo is bar.  A foo can be notable.
Baz relates a person to a foo.
When play begins:
	showme whether or not a foo (called quux) is notable;
	say "[quux]."
Additional InformationNote that the cause here is distinct from that in 0001099, though it may be possible to squash both with one fix.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002447)
graham (administrator)
2014-02-04 01:27

Though not strictly the same as 0001099, the same mechanism fixed both.

- Issue History
Date Modified Username Field Change
2013-04-19 20:51 EmacsUser New Issue
2013-04-20 09:20 zarf Status new => confirmed
2014-02-04 01:27 graham Note Added: 0002447
2014-02-04 01:27 graham Status confirmed => resolved
2014-02-04 01:27 graham Resolution open => fixed
2014-02-04 01:27 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker