Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001104Core InformExtensionspublic2013-04-19 19:562014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001104: Compiler rejects inclusions after the last section in an .i6t
DescriptionThe attached source provokes

- - - -
Problem. You wrote 'Include (- after "Debugging" in "Rulebooks.i6t"': but that template file didn't have a part with that name, so this attempt to intervene had no effect. Each template file is divided internally into a number of named parts, and you have to quote their names precisely. (Looking at the typeset form of the template, available at the Inform website, may help.)
- - - -

which, besides misquoting the source text (perhaps 0000883?), is inaccurate because such a section does exist—inclusions before or instead of it compile.
Minimal Source Text To Reproduce
There is a room.
Include (- -) after "Debugging" in "Rulebooks.i6t".
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0002025)
zarf (developer)
2013-04-20 08:13

Confirmed.
(0002304)
graham (administrator)
2014-01-18 09:07

Fixed.

- Issue History
Date Modified Username Field Change
2013-04-19 19:56 EmacsUser New Issue
2013-04-20 08:13 zarf Note Added: 0002025
2013-04-20 08:13 zarf Assigned To => zarf
2013-04-20 08:13 zarf Status new => confirmed
2013-04-20 08:24 zarf Assigned To zarf =>
2014-01-18 09:07 graham Note Added: 0002304
2014-01-18 09:07 graham Status confirmed => resolved
2014-01-18 09:07 graham Resolution open => fixed
2014-01-18 09:07 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker