Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001103Core InformPropertiespublic2013-04-06 19:222014-05-07 07:34
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001103: Compiler rejects implicitly named properties with kinds that are strict subtypes of object
DescriptionThe attached source is rejected with

- - - -
Problem. You wrote 'A person has a region': but this looked to me as if it might be trying to create something which has certain properties, and that made no sense on investigation. This sometimes happens if a sentence uses 'with' a little too liberally, or to specify a never-declared property. For instance, 'An antique is a kind of thing with an age.' would not be the right way to declare the property 'age' (because it does not tell Inform what kind of value this would be). Instead, try 'An antique is a kind of thing. An antique has a number called age.' It would then be all right to say 'The Louis Quinze chair is an antique with age 241.'
- - - -
Minimal Source Text To Reproduce
There is a room.
A person has a region.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
zarf (developer)
2013-04-07 20:42


As the summary implies, "A person has an object" and "A person has a text" both work. "A person has a thing" and "A person has a room" both fail.

("A person has a number" is accepted but confuses the Standard Rules -- phrases like "number of things carried by the actor" wind up misparsed. I don't consider that a bug, but I ran into it, so I figured I should mention it.)

EmacsUser (manager)
2013-04-08 09:03

``... has a number'' is 0000517, already fixed.
graham (administrator)
2014-01-12 15:15


- Issue History
Date Modified Username Field Change
2013-04-06 19:22 EmacsUser New Issue
2013-04-07 20:42 zarf Note Added: 0002007
2013-04-07 20:42 zarf Status new => confirmed
2013-04-08 09:03 EmacsUser Note Added: 0002017
2014-01-12 15:15 graham Note Added: 0002286
2014-01-12 15:15 graham Status confirmed => resolved
2014-01-12 15:15 graham Resolution open => fixed
2014-01-12 15:15 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker