Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000110Core InformPhrases and functional programmingpublic2010-06-23 14:512010-07-01 23:07
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000110: invoking a phrase that begins with a number doesn't compile unless number is spelled out
DescriptionIn the code below, I get a spurious error about the word otherwise being misplaced (i.e., outside an if-block). But if I spell out the number 5 as five, it compiles normally.

(It doesn't matter which number I use. But spelling it out always works correctly.)
Minimal Source Text To Reproduce
To (T - a number) more minutes dear: 
	if T is not 1:
		5 more minutes dear;
	otherwise:
		say "Taps foot."

		
spot is room.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0000138)
Ron Newcomb (reporter)
2010-06-23 14:52

Er, the field 'effect' should be "Inform *7* compiler reports errors for valid code". I didn't look closely upon submitting, sorry.
(0000142)
EmacsUser (manager)
2010-06-23 18:05
edited on: 2010-06-23 18:17

Like Ron said, this issue seems to be a statement beginning with a numeral. The addition of a word like ``only'' before the phrase's first argument eliminates the complaint:

To only (T - a number) more minutes dear:
if T is not 1:
only 5 more minutes dear;
otherwise:
say "Taps foot."
Spot is a room.

(0000197)
graham (administrator)
2010-06-30 14:58

There's a curious one. Inform was overzealously applying its rule that a punctuation mark with digits either side doesn't break a sentence - this is what allows notations like "2:31 AM" and "3.24" not to break sentences. It didn't anticipate a line break and tabs in between the colon and the second digit...

- Issue History
Date Modified Username Field Change
2010-06-23 14:51 Ron Newcomb New Issue
2010-06-23 14:52 Ron Newcomb Note Added: 0000138
2010-06-23 15:47 jmcgrew Effect (critical) Inform 6 compiler reports errors for valid code => (serious) Compiler rejects valid code
2010-06-23 15:47 jmcgrew Status new => acknowledged
2010-06-23 15:47 jmcgrew Steps to Reproduce Updated View Revisions
2010-06-23 18:05 EmacsUser Note Added: 0000142
2010-06-23 18:05 EmacsUser Status acknowledged => confirmed
2010-06-23 18:17 EmacsUser Note Edited: 0000142 View Revisions
2010-06-30 14:58 graham Note Added: 0000197
2010-06-30 14:58 graham Status confirmed => resolved
2010-06-30 14:58 graham Resolution open => fixed
2010-06-30 14:58 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker