Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001098Core InformKinds and type checkingpublic2013-04-06 18:572014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001098: Problem message about value vs. stored value could be made clearer
DescriptionThe term ``stored value'' appears in problem messages like the one for the attached source text, but is only explained under a deprecation warning in WI 8.1. Perhaps it would help to add some explanatory text to the problem message, or a documentation link, or else define ``stored value'' in the main content of WI.

- - - -
Problem. You wrote 'increment the number that the location relates to by the foo of yourself', but 'number that the location relates to by the foo of yourself' seems to be an instruction to work out a value, whereas I was expecting to find a stored value there.
- - - -
Minimal Source Text To Reproduce
There is a room.
A person has a relation of rooms to numbers called priority.
Every turn:
	increment the number that the location relates to by the priority of yourself.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0002013)
zarf (developer)
2013-04-07 21:26

I stared at this example for a bit before I realized that the relation was a red herring! (Sorry, slow tonight...)

Simpler:

To decide what number is the zork: decide on 3.
Every turn: increment the zork.
(0002014)
zarf (developer)
2013-04-07 21:26

Confirmed.
(0002015)
zarf (developer)
2013-04-08 08:44

(Or. indeed, just "Every turn: increment 3." If we're talking simple examples.)

- Issue History
Date Modified Username Field Change
2013-04-06 18:57 EmacsUser New Issue
2013-04-07 21:26 zarf Note Added: 0002013
2013-04-07 21:26 zarf Note Added: 0002014
2013-04-07 21:26 zarf Status new => confirmed
2013-04-08 08:44 zarf Note Added: 0002015
2014-01-25 03:05 graham Status confirmed => resolved
2014-01-25 03:05 graham Resolution open => fixed
2014-01-25 03:05 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker