Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001095Core InformRules and rulebookspublic2013-04-04 09:442014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001095: No phrase to get value produced by a nothing based rule
DescriptionWI gives phrases for obtaining the values produced by an action-based rule or a rule based on a non-void kind, but there is no phrase for nothing-based rules.
Minimal Source Text To Reproduce
There is a room.
Foo is a nothing based rulebook producing numbers.
When play begins:
	showme the number produced by foo.
Additional InformationThe problem message for the attached source is unhelpful, but that's a separate bug, already marked fixed.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
related to 0000759closedgraham can't follow/consider some rulebooks 

-  Notes
(0002003)
zarf (developer)
2013-04-04 11:44

Confirmed.

This is a direct analog of 759, it looks like. We have definitions

   To follow (RL - a rule) [implictly "action-based rule"]

   To follow (RL - value of kind K based rule producing a value) for (V - K)

   To decide what K is the (name of kind K) produced by (RL - rule producing a value of kind K) [implictly "action-based rule"]

   To decide what L is the (name of kind L) produced by (RL - value of kind K based rule producing a value of kind L) for (V - K)

In both patterns, we need a third phrase for nothing-based rules.

(0002272)
graham (administrator)
2014-01-12 07:07

A third phrase definition has been added, as that seems the cleanest fix.

- Issue History
Date Modified Username Field Change
2013-04-04 09:44 EmacsUser New Issue
2013-04-04 09:46 EmacsUser Relationship added related to 0000759
2013-04-04 11:44 zarf Note Added: 0002003
2013-04-04 11:44 zarf Status new => confirmed
2014-01-12 07:07 graham Note Added: 0002272
2014-01-12 07:07 graham Status confirmed => resolved
2014-01-12 07:07 graham Resolution open => fixed
2014-01-12 07:07 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker