Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000109Core InformAssertions and creationspublic2010-06-23 14:422010-10-28 00:31
Reporteremail 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000109: Creating an object with the opposite of a comparative adjective compiles but doesn't work
DescriptionProblem is that the assertion definition shouldn't allow 'rather than' if you can't use the 'rather than' part to assert with.
Minimal Source Text To Reproduce
Every device has a number called cpu power. The cpu power of a device is usually 25.

Definition: A device is complex rather than simple if its cpu power is 50 or more. [This assertion definition 
compiles.]

The lab is a room.

A complex device called a computer is in the lab.
A simple device called a netbook is in the lab. [Using 'simple' as an assertion compiles but makes a 
complex device.]
A device called a tablet is in the lab.

Instead of examining a simple device, say "Simple."
Instead of examining a complex device, say "Complex."

[Problem is that the assertion definition shouldn't allow 'rather than' if you can't use the 'rather 
than' part to assert with.]

Test me with "showme computer/showme netbook/showme tablet/x computer/x netbook/x tablet". 
Additional InformationMake the 'rather than' part correctly assert or don't allow the 'rather than' part in the definition or generate a compiler error telling the user he cannot use the 'rather than' part as an assertion.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000137)
jmcgrew (administrator)
2010-06-23 14:45

This could be a "compiler accepts invalid code" issue: if creating a "simple" device is not intended to work, then either the definition of "simple" or the device assertion should cause a compile-time error.
(0000616)
graham (administrator)
2010-09-29 03:25

Yes, Inform should have produced a problem message in reply to

A simple device called a netbook is in the lab.

and now does so. The line

A complex device called a computer is in the lab.

is on the other hand legal, because Inform can infer a reasonable decision from it - to create the computer with the threshold value, i.e., with cpu power 50.

- Issue History
Date Modified Username Field Change
2010-06-23 14:42 jmcgrew New Issue
2010-06-23 14:45 jmcgrew Note Added: 0000137
2010-06-23 14:45 jmcgrew Status new => acknowledged
2010-06-23 14:49 jmcgrew Additional Information Updated View Revisions
2010-06-23 17:59 EmacsUser Status acknowledged => confirmed
2010-09-29 03:25 graham Note Added: 0000616
2010-09-29 03:25 graham Status confirmed => resolved
2010-09-29 03:25 graham Resolution open => fixed
2010-09-29 03:25 graham Assigned To => graham
2010-10-24 12:04 jmcgrew Reporter jmcgrew => email
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker