Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001089Core InformSource text and punctuationpublic2013-03-19 09:012014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001089: Confusing problem message for wrong kind of quotes around text
DescriptionThe attached source provokes

- - - -
Problem. The sentence 'Foo is 'bar'' tells me that 'Foo', which is a text that varies, should start out with the value ''bar'', but this is an object and not a text.
- - - -

which is confusing first because of the implicit object creation and second because the additional single quotes create the appearance of double quotes in the error report. I'm not sure what a good improvement might be—perhaps this should be a special case?
Minimal Source Text To Reproduce
There is a room.
Foo is some text that varies.
Foo is 'bar'.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-03-19 09:01 EmacsUser New Issue
2013-03-30 04:30 jmcgrew Status new => confirmed
2014-01-25 02:18 graham Status confirmed => resolved
2014-01-25 02:18 graham Resolution open => fixed
2014-01-25 02:18 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker