Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001081Core InformScenespublic2013-02-20 05:522014-05-07 07:33
ReporterFelix Larsson 
Assigned Tograham 
StatusclosedResolutionno change required 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001081: Scene changing rules conditional upon an action having been performed N times get the number wrong
DescriptionA scene begins rule like ┬╗Scene S begins when we have performed action A for the N:th time.┬╗ will start the scene before we have performed A N times.
Minimal Source Text To Reproduce
Immanentizing the Eschaton is a scene.
Immanentizing the Eschaton begins when we have examined the grail for the fifth time.
When immanentizing the Eschaton begins, say "Kingdom comes."

The Place is a room.
The grail is in place.

Test me with "x grail / g / g / g / g "
Additional InformationPresumably, this is to do with the scene changing rules being considered twice during the turn sequence.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0001186closedgraham Documentation, Examples, and Web Site WI 9.14 seems to contradict 0001081:0002369 

-  Notes
zarf (developer)
2013-02-20 19:38

Considering the scene changing rules twice should be harmless, because testing the condition twice should not change its behavior.

In fact it does, which looks like a bug all by itself:

To decide whether the zorko:
if we have examined the grail for the sixth time:
decide yes.

Every turn:
if the zorko, say "Z1.";
if the zorko, say "Z2.";
if the zorko, say "Z3.";

This begins to trigger after just two "examine grail" commands. (In fact it begins to trigger at "Z3", which shows that the condition result in the middle of a rule.)
zarf (developer)
2013-02-20 19:39

Also, all these bugs persist if you change "for the sixth time" to "six times". (A distinction which I can never keep straight, but it doesn't matter here.)
zarf (developer)
2013-02-20 19:40

graham (administrator)
2014-01-25 14:17

As horrid as it is, this behaviour is correct. It tests whether the condition "we have examined the grail" is true for the 5th time of asking, not whether there have been five such actions. This is not to do with scenes at all, and the same would be true if the condition were used in e.g.:

Every turn:
repeat with X running through things:
if we have examined the grail for the fifth time:
say "Hello."

where the condition is tested some unpredicatable (ish) number of times.

- Issue History
Date Modified Username Field Change
2013-02-20 05:52 Felix Larsson New Issue
2013-02-20 19:38 zarf Note Added: 0001980
2013-02-20 19:39 zarf Note Added: 0001981
2013-02-20 19:40 zarf Note Added: 0001982
2013-02-20 19:40 zarf Assigned To => graham
2013-02-20 19:40 zarf Status new => confirmed
2014-01-25 14:17 graham Note Added: 0002369
2014-01-25 14:17 graham Status confirmed => resolved
2014-01-25 14:17 graham Resolution open => no change required
2014-01-25 17:07 EmacsUser Issue cloned 0001186
2014-01-25 17:07 EmacsUser Relationship added related to 0001186
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker