Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000108Core InformListspublic2010-06-23 14:232010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000108: Comparing a list with a constant empty list always gives a negative result
DescriptionThe test in the example source fails, even though L is an empty list being compared with another empty list.
Minimal Source Text To Reproduce
Home is a room.

When play begins:
	let L be a list of numbers;
	if L is {}, say "Test succeeded.";
	otherwise say "Test failed."
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000507)
graham (administrator)
2010-09-04 01:14

Fixed. The lists were considered different because although both were empty, they had different kinds of entries according to Inform's internal book-keeping; L was a list of numbers, whereas {} was a list of generic values.

- Issue History
Date Modified Username Field Change
2010-06-23 14:23 fundin New Issue
2010-06-23 14:38 jmcgrew Status new => confirmed
2010-09-04 01:14 graham Note Added: 0000507
2010-09-04 01:14 graham Status confirmed => resolved
2010-09-04 01:14 graham Resolution open => fixed
2010-09-04 01:14 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker