Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001069Core InformAssertions and creationspublic2013-01-23 12:362014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001069: Compiler ignores some contradictions introduced by ``here is''
DescriptionThe attached code compiles, unexpectedly. The similar code,

- - - -
Beginning is a room.
A chair is in Beginning.
Finale is north of Beginning.
A chair is in Finale.
- - - -

is diagnosed with the proper problem message.
Minimal Source Text To Reproduce
Beginning is a room.
A chair is here.
Finale is north of Beginning.
A chair is here.
Additional InformationTaken from http://www.intfiction.org/forum/viewtopic.php?f=7&t=6883. [^]
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships

-  Notes
(0001958)
zarf (developer)
2013-01-23 19:09
edited on: 2013-01-23 19:10

Confirmed. The compiler seems to be checking for contradictory declarations before resolving "here" in them. (So we wind up with a single chair, in the first room named.)

You can demonstrate this the opposite way:

Beginning is a room.
A chair is here.
A chair is in the Beginning.

This throws a problem message, even though the two declarations are compatible: "You wrote 'A chair is here' , but in another sentence 'A chair is in the Kitchen' : chair can only be given its position once, in a single assertion sentence."

Whereas if you say:

Beginning is a room.
A chair is in the Beginning.
A chair is in the Beginning.

...it compiles fine.

(0001959)
zarf (developer)
2013-01-23 19:12

(Sorry, screwed up the issue status.)
(0002662)
graham (administrator)
2014-05-04 09:45

This now produces an explanatory problem message.

- Issue History
Date Modified Username Field Change
2013-01-23 12:36 EmacsUser New Issue
2013-01-23 19:09 zarf Note Added: 0001958
2013-01-23 19:09 zarf Assigned To => zarf
2013-01-23 19:09 zarf Status new => confirmed
2013-01-23 19:10 zarf Note Edited: 0001958 View Revisions
2013-01-23 19:11 zarf Assigned To zarf => graham
2013-01-23 19:11 zarf Status confirmed => assigned
2013-01-23 19:12 zarf Note Added: 0001959
2013-01-23 19:12 zarf Status assigned => confirmed
2014-05-04 09:45 graham Note Added: 0002662
2014-05-04 09:45 graham Status confirmed => resolved
2014-05-04 09:45 graham Resolution open => fixed
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker