Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001066Core InformActionspublic2013-01-14 18:232014-05-07 07:33
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001066: including "For the first time" in a disjunctive description of actions to avoid yields a slightly confusing error message
DescriptionThe following source code yields this error message:

Problem. You wrote 'Instead of doing anything other than looking for the first time or waiting or examining' , which seems to introduce a rule taking effect only if the action is 'doing anything other than looking for the first time or waiting or examining'. But that did not make sense as a description of an action. This looks like a list of actions to avoid: 'looking for the first time' was okay; 'waiting' was okay; 'examining' was okay; so I am unable to place this rule into any rulebook.
 See the manual: 7.1 > Actions

Note that all three action descriptions are described as "okay," leaving it unclear where the problem is.
Minimal Source Text To Reproduce
Monastery is a room.

Instead of doing anything other than looking for the first time or waiting or examining: say "Don't 
get distracted!"
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-01-14 18:23 mattweiner New Issue
2013-01-15 15:02 EmacsUser Status new => confirmed
2014-01-24 15:16 graham Status confirmed => resolved
2014-01-24 15:16 graham Resolution open => fixed
2014-01-24 15:16 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker