Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001065Core InformReleasing, bibliographic data, cBlorbpublic2013-01-10 15:032014-05-07 07:33
ReporterJuhana 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001065: The ni compiler outputs error messages to stdout
DescriptionThe ni compiler puts error messages to stdout, and the progress percentages to stderr. It's a slight inconvenience when making command line scripts to automate story compilation.
Minimal Source Text To Reproduce
Trying to compile an empty file, stdout:

Inform 7 build 6K11 has started.
I've now read the source text, which is 0 words long.
I've also read Standard Rules by Graham Nelson, which is 41434 words long.
I've also read English Language by Graham Nelson, which is 1959 words long.
  >--> There doesn't seem to be any location in this story, so there's nowhere
    for the player to begin. This may be because I have misunderstood what was
    meant to be a room and what wasn't: I only know something is a room if you
    tell me explicitly ('The Observatory is a room') or if you imply it by
    giving map directions ('East of the Observatory is the Planetarium').
Inform 7 has finished.


stderr:

++ 0% (Lexical analysis)
++ 5% (Semantic analysis)
++ 15% (Drawing inferences)
Tagswrongeffect
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002537)
graham (administrator)
2014-03-09 03:32

There was at one time a reason to do with the automated testing framework why problem messages were issued to stdout, not stderr, but that's no longer an issue. I've moved them to stderr. (Fatal errors were already there.)

The progress percentages are printed to stderr because we need to avoid buffering which makes stdout less responsive in the OS X app, if memory serves: if these messages are received a second or two late, they lose their purpose. But they can be suppressed with the -noprogress command-line switch.

- Issue History
Date Modified Username Field Change
2013-01-10 15:03 Juhana New Issue
2013-01-13 17:54 EmacsUser Status new => confirmed
2013-01-13 17:54 EmacsUser Tag Attached: wrongeffect
2014-03-09 03:32 graham Note Added: 0002537
2014-03-09 03:32 graham Status confirmed => resolved
2014-03-09 03:32 graham Resolution open => fixed
2014-03-09 03:32 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker