Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001053Documentation, Examples, and Web SiteExamplespublic2012-12-04 05:412014-05-07 07:38
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001053: Several examples use procedural rules
DescriptionExamples 112 ("A Day For Fresh Sushi"), 195 ("Paddington"), 214 ("Slogar's Revenge), 227 ("Transmutation"), and 365 ("Lollipop Guild") all contain procedural rules. So does example 390 ("Access All Areas"), but that's in the section on procedural rules so that's OK.
Additional InformationPerhaps "A Day For Fresh Sushi" should be left as is for historical purposes, but it seems to me that the other examples should at least be tagged with the Beta symbol for deprecated features.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001944)
vyznev (reporter)
2012-12-19 14:00

Once the next release is out, most of these could presumably be replaced with conditional rule suppression: http://inform7.uservoice.com/forums/57320-general/suggestions/837651-syntax-a-way-to-change-the-condition-of-an-exist [^]

In any case, the single procedural rule in "A Day For Fresh Sushi" is only a small cosmetic tweak (not listing the contents of the aquarium when examining it), and I'm not even sure why it's there to begin with. Commenting it out doesn't appear to have any significant adverse effect.

As for Slogar's Revenge, the procedural rules in it seem completely pointless, since the example works just fine without them. I suspect they may have been a workaround for an old bug that has since been fixed, and should just be removed.
(0002360)
graham (administrator)
2014-01-25 09:44

This is indeed cleaned out in the new build.

- Issue History
Date Modified Username Field Change
2012-12-04 05:41 mattweiner New Issue
2012-12-12 13:42 EmacsUser Status new => confirmed
2012-12-19 14:00 vyznev Note Added: 0001944
2014-01-25 09:44 graham Note Added: 0002360
2014-01-25 09:44 graham Status confirmed => resolved
2014-01-25 09:44 graham Resolution open => fixed
2014-01-25 09:44 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker