Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000105Core InformPhrases and functional programmingpublic2010-06-23 13:542010-10-28 00:32
Reporterfundin 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000105: Phrases applying only to specific values don't work for some KOVs
DescriptionOf the two phrases in the example source, the generic one is invoked rather than the one applying to the specific value.
Minimal Source Text To Reproduce
Home is a room.

To consider (L - a list of numbers): say "Just some list."

To consider (L - {3}): say "A specific list."

When play begins: consider {3}.
Additional InformationThis also affects other kinds of values, or at any rate references to phrases, which is what I was originally working with.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
related to 0000368closedgraham No dynamic dispatch for phrases applying to specific phrases 

-  Notes
(0000139)
EmacsUser (manager)
2010-06-23 17:25

The issue is that the latter phrase is not matched at all. A reduced test case:

There is a room.
To check (L - {3}): stop.
When play begins: check {3}.


This code yields the error:

Problem. In the sentence 'check {3}' , I was expecting that '{3}' would be the specific value '{ 3 }'.
I was trying to match this phrase:

check ({ 3 } - { 3 })
This was what I found out:

{3} = a list of numbers
(0000195)
graham (administrator)
2010-06-30 13:59

Fixed.
(0000237)
fundin (reporter)
2010-07-05 06:40

Okay. Lists now work, but phrase references still have the same problem. Test case:

Home is a room.

To waste time (this is wasting time): do nothing.
To disregard (P - wasting time): do nothing.

When play begins: disregard wasting time.
(0000574)
graham (administrator)
2010-09-21 16:52

It would be helpful not to reopen these things with fresh test cases down in the notes - I spent a short while investigating the original test case and found, of course, that it was working fine... However, the second test case (an unrelated bug) is also now fixed, so this issue is well and truly resolved.

- Issue History
Date Modified Username Field Change
2010-06-23 13:54 fundin New Issue
2010-06-23 14:36 jmcgrew Status new => acknowledged
2010-06-23 17:25 EmacsUser Note Added: 0000139
2010-06-23 17:25 EmacsUser Status acknowledged => confirmed
2010-06-23 17:26 EmacsUser Effect (serious/mild) Game compiles but misbehaves => (serious) Compiler rejects valid code
2010-06-23 17:26 EmacsUser Severity mild => serious
2010-06-30 13:59 graham Note Added: 0000195
2010-06-30 13:59 graham Status confirmed => resolved
2010-06-30 13:59 graham Resolution open => fixed
2010-06-30 13:59 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed
2010-07-05 06:40 fundin Note Added: 0000237
2010-07-05 06:40 fundin Status closed => feedback
2010-07-05 06:40 fundin Resolution fixed => reopened
2010-07-06 13:18 jmcgrew Status feedback => acknowledged
2010-07-07 12:18 EmacsUser Status acknowledged => confirmed
2010-09-21 16:52 graham Note Added: 0000574
2010-09-21 16:52 graham Status confirmed => resolved
2010-09-21 16:52 graham Resolution reopened => fixed
2010-10-28 00:32 jmcgrew Status resolved => closed
2010-10-29 09:04 jmcgrew Relationship added related to 0000368


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker