Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001049Core InformTablespublic2012-11-13 18:342014-05-07 07:33
Reporterjorendorff 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001049: The phrase "X is a C listed in T" is inexplicably sexist
DescriptionYou can add as many men and women as you like to this table; Inform will consider the men to be "listed in" the table, but not the women!

Inform must be inferring a wrong type for the column. If a woman is listed first, Inform instead only recognizes women. If I add `A toaster is in Ohio.` and change the first row of the table to `toaster`, it recognizes both women and men.

Explicitly changing the column heading to `voter (object)` also works.
Minimal Source Text To Reproduce
Ohio is a room. Jane is a woman. Jon is a man.

Table 1
voter
Jon
Jane

When play begins:
	if Jane is a voter listed in Table 1:
		say "PASS";
	else:
		say "FAIL";
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
duplicate of 0000448closedgraham Kind of table column is determined solely according to the first table, but later mismatches compile 
related to 0000444closedgraham Inform ignores explicit typing for table columns 

-  Notes
(0001927)
EmacsUser (manager)
2012-11-15 11:54

Confirmed, noting 0000444:0000870, and with a suspicion that the fix described in 0000444:0001422 has already taken care of the problem.
(0002371)
graham (administrator)
2014-01-25 14:47

Fixed. (It was actually a duplicate of 0000448, not 0000444.)

- Issue History
Date Modified Username Field Change
2012-11-13 18:34 jorendorff New Issue
2012-11-15 11:54 EmacsUser Note Added: 0001927
2012-11-15 11:54 EmacsUser Status new => confirmed
2012-11-15 11:54 EmacsUser Relationship added related to 0000444
2014-01-25 14:47 graham Note Added: 0002371
2014-01-25 14:47 graham Status confirmed => resolved
2014-01-25 14:47 graham Resolution open => fixed
2014-01-25 14:47 graham Assigned To => graham
2014-01-25 16:54 EmacsUser Resolution fixed => duplicate
2014-01-25 16:54 EmacsUser Relationship added duplicate of 0000448
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker