Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001047Core InformListspublic2012-11-11 22:172014-05-07 07:33
Reporterjorendorff 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001047: Internal error when a temporary named value is used as an entry in a constant list
DescriptionI would expect to get something like:

    The constant list 'it' contains an entry 'it' which does make sense,
    but isn't a constant (it's a temporary named value).

Instead, the accompanying source text causes an internal error:

    This is the report produced by Inform 7 (build 6G60) on its most recent
    run through:

    Problem. An internal error has occurred: bad const check-against in
    run-time type check. The current sentence is 'jog {it}' ; the error was
    detected at line 928 of "Chapter 22/Compile Invocations.w". This should
    never happen, and I am now halting in abject failure.
Minimal Source Text To Reproduce
Home is a room.
To jog (those - a list of things):
	do nothing.
To rig (it - a thing):
	jog {it}.
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0002379)
graham (administrator)
2014-01-26 02:05

I'm promoting this to serious since it's an internal error, but anyway it's fixed.

- Issue History
Date Modified Username Field Change
2012-11-11 22:17 jorendorff New Issue
2012-11-13 12:32 EmacsUser Status new => confirmed
2012-11-13 12:32 EmacsUser Category Kinds and type checking => Lists
2014-01-26 02:05 graham Note Added: 0002379
2014-01-26 02:05 graham Status confirmed => resolved
2014-01-26 02:05 graham Resolution open => fixed
2014-01-26 02:05 graham Assigned To => graham
2014-01-26 02:06 graham Severity mild => serious
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker