Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001046Core InformPropertiespublic2012-11-07 17:112014-05-07 07:33
Reporterzarf 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001046: Property verb doesn't work for "a room"
DescriptionThe sample code does not locate a room with a given size property.

Minimal Source Text To Reproduce
"Test Case" by Andrew Plotkin.

A room has a number called the size.
The verb to measure (it measures, they measure, it is measuring) implies the size property.

The Kitchen is a room. The size is 3.
The Bathroom is a room. The size is 5.

When play begins:
	if a room (called R) measures 3:
		say "[R] is 3.";
	if a room (called R) measures 5:
		say "[R] is 5.";
	say "But the size of the Kitchen is [the size of the Kitchen]."
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000376closedgraham Enclosure doesn't work for "a room" 

-  Notes
(0001924)
zarf (developer)
2012-11-07 17:12

This looks like the same root cause as bug 376, but I'm filing it separately just in case.

The generated code expects the object to be both a room and a thing, which is impossible:


! True or false?
! [ Exists x : room(x) & thing(x) & called='r'(x) & set-property(x, '3') ]
[ Prop_0 x x_ix ;
    for (x=IK2_First: x: x=x.IK2_Link){
        if ((x ofclass K1_room) && (x.p13_size == 3)){
            deferred_calling_list-->0 = x;
            rtrue;
        }
    }
    rfalse;
];
(0002556)
graham (administrator)
2014-03-13 12:40

It's a different bug from 376, but it's also fixed.

- Issue History
Date Modified Username Field Change
2012-11-07 17:11 zarf New Issue
2012-11-07 17:12 zarf Note Added: 0001924
2012-11-07 17:13 zarf Relationship added related to 0000376
2012-11-08 09:55 EmacsUser Status new => confirmed
2014-03-13 12:40 graham Note Added: 0002556
2014-03-13 12:40 graham Status confirmed => resolved
2014-03-13 12:40 graham Resolution open => fixed
2014-03-13 12:40 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker