Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001044Core InformActionspublic2012-11-02 03:102014-05-07 07:33
Reportercuriousdannii 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001044: Trying actions doesn't reset the meta variable
DescriptionTrying actions doesn't reset the meta variable. Potentially this is by design, but I can't think of a reason why it would be. If you deliberately try a non-out-of-world action from an out-of-world action it should work.

(When I say reset I mean push/pull the meta var like the others are.)
Minimal Source Text To Reproduce
There is a room.
Here is a man called Bob.
First carry out quitting the game:
	try Bob looking.
Test me with "quit".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001921)
zarf (developer)
2012-11-04 08:52

My sense is that this has never been supported (although there's no documentation about it).

The meta flag has some effects down in the action-tracking machinery that might make this tricky. Not sure.

Note that even if this is supported, there will be no "every turn" phase for the command (because the top-level action is meta). That might screw up somebody's invariant.
(0001922)
EmacsUser (manager)
2012-11-04 15:59

meta is saved, just in the local smeta, rather than on the stack (I think this was a fix in 6E59). But the flag isn't subsequently cleared, so it's only possible to properly try a out-of-world action from an in-world one, not vice versa. I think I'll confirm this, despite the injunction in WI 12.15, as the fix is only one otherwise innocuous line added to TryAction.
(0002391)
graham (administrator)
2014-01-27 10:25

I've accepted this, though I actually chose to fix it in ActionVariablesNotTypeSafe, which sets the meta flag when needed but did not previously clear it when not. I think it's legal to try an in-world action from an out-of-world one (and indeed GONEAR does this), but really, at your own risk.

- Issue History
Date Modified Username Field Change
2012-11-02 03:10 curiousdannii New Issue
2012-11-02 04:52 curiousdannii Description Updated View Revisions
2012-11-04 08:52 zarf Note Added: 0001921
2012-11-04 15:59 EmacsUser Note Added: 0001922
2012-11-04 15:59 EmacsUser Reproducibility have not tried => always
2012-11-04 15:59 EmacsUser Status new => confirmed
2014-01-27 10:25 graham Note Added: 0002391
2014-01-27 10:25 graham Status confirmed => resolved
2014-01-27 10:25 graham Resolution open => fixed
2014-01-27 10:25 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker