Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001043Documentation, Examples, and Web SiteWriting with Informpublic2012-10-30 09:482014-05-07 07:38
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001043: Inline example code from WI 18.12 does not compile
DescriptionThe example leads to the problem message

- - - -
Problem. You wrote 'remove the destroyed object' : but this is a phrase which I don't recognise, possibly because it is one you meant to define but never got round to, or because the wording is wrong (see the Phrasebook section of the Index to check). Alternatively, it may be that the text immediately previous to this was a definition whose ending, normally a full stop, is missing?
- - - -

because ``remove the destroyed object'' should be ``remove the destroyed object from play''.
Minimal Source Text To Reproduce
There is a room.
Austin is an animal.  The ball of wool is a thing.
The cat behavior rules is a rulebook producing an object.
Cat behavior when Austin can see the ball of wool: 
	rule succeeds with result the ball of wool.
Every turn: 
	let the destroyed object be the object produced by the cat behavior rules; 
	if the destroyed object is not nothing: 
		say "Austin pounces on [the destroyed object] in a flurry."; 
		remove the destroyed object.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-10-30 09:48 EmacsUser New Issue
2012-11-02 03:39 curiousdannii Status new => confirmed
2014-01-25 09:20 graham Status confirmed => resolved
2014-01-25 09:20 graham Resolution open => fixed
2014-01-25 09:20 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker