Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001038Core InformAssertions and creationspublic2012-10-19 08:022014-05-07 07:34
Reporterherrdu 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001038: Specifically named part of a generic object causes internal error
DescriptionWhen creating an object generically with the called clause and making it part of another generic object without a called clause causes an internal error.

Obviously the parent object needs a called clause (which will then succeed in compiling). The compiler should produce a better error message.
Minimal Source Text To Reproduce
Example is a room.

A table is a kind of supporter.  One table is in every room.

A drawer is a kind of container.  One drawer (called its drawer) is part of every table.
Additional InformationInform 7 build 6G60 has started.
I've now read your source text, which is 34 words long.
I've also read Standard Rules by Graham Nelson, which is 39455 words long.

Compiler finished with code 10
TagsNo tags attached.
Effect(critical) Compiler crashes
Attached Files

- Relationships

-  Notes
(0001914)
EmacsUser (manager)
2012-10-20 12:47

Confirmed:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000
0x922ab090 in strcpy ()
(gdb) bt
#0 0x922ab090 in strcpy ()
#1 0x00019b26 in Text__print_raw_text_to_string ()
#2 0x0013276c in Parser__Assertions__convert_instance_to_nounphrase ()
#3 0x00133b0e in make_assertion_recursive_inner ()
#4 0x00135d75 in Parser__Assertions__make_assertion_recursive ()
#5 0x00136e74 in Parser__Assertions__make_assertion ()
#6 0x00137e19 in to_be ()
#7 0x000a3673 in Parser__Assertions__traverse ()
#8 0x0012b932 in Config__Template__interpret ()
#9 0x001314bc in main ()
(gdb)

Possibly, but probably not, a duplicate of 0000925.

- Issue History
Date Modified Username Field Change
2012-10-19 08:02 herrdu New Issue
2012-10-20 12:47 EmacsUser Effect (critical) Compiler reports internal error => (critical) Compiler crashes
2012-10-20 12:47 EmacsUser Note Added: 0001914
2012-10-20 12:47 EmacsUser Severity mild => critical
2012-10-20 12:47 EmacsUser Reproducibility have not tried => always
2012-10-20 12:47 EmacsUser Status new => confirmed
2012-10-20 12:47 EmacsUser Category Kinds and type checking => Assertions and creations
2014-01-05 10:14 graham Status confirmed => resolved
2014-01-05 10:14 graham Resolution open => fixed
2014-01-05 10:14 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker