Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000103Core InformRelationspublic2010-06-22 14:162010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000103: Static relations of lists are created with the wrong type
DescriptionThe relation in the example source seems to be correctly initialised, but the test gives a negative result.
Minimal Source Text To Reproduce
Home is a room.

Partnership relates various lists of numbers to various lists of numbers. The verb to belong with (he 
belongs with, they belong with) implies the partnership relation.

{3} belongs with {7}.

When play begins:
	if {3} belongs with {7}, say "Test succeeded.";
	otherwise say "Test failed."
Additional InformationAFAICT, only lists are affected by this problem.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000134)
jmcgrew (administrator)
2010-06-22 19:56
edited on: 2010-06-22 20:03

I7 is erroneously setting the relation's type to "relation of lists of values to lists of values": it should be "relation of lists of numbers to lists of numbers". This causes the copy of the list inside the relation to have the type "list of values", so it doesn't match the "list of numbers" that is later used to search the relation.

This affects all types of lists; the relation of numbers in this example only appears to be correctly initialized because untyped values are printed as numbers.

(0000613)
graham (administrator)
2010-09-29 02:26

Fixed. A complicated one; it was internally representing the domains of a relation in terms of the inferences which could be drawn about them, but that didn't sufficiently distinguish different kinds of lists.

- Issue History
Date Modified Username Field Change
2010-06-22 14:16 fundin New Issue
2010-06-22 15:11 jmcgrew Assigned To => jmcgrew
2010-06-22 15:11 jmcgrew Status new => acknowledged
2010-06-22 18:09 jmcgrew Status acknowledged => confirmed
2010-06-22 18:10 jmcgrew Status confirmed => assigned
2010-06-22 19:56 jmcgrew Note Added: 0000134
2010-06-22 19:56 jmcgrew Assigned To jmcgrew =>
2010-06-22 19:56 jmcgrew Status assigned => confirmed
2010-06-22 20:02 jmcgrew Summary Testing relations of lists always gives a negative result => Static relations of lists are created with the wrong type
2010-06-22 20:03 jmcgrew Note Edited: 0000134 View Revisions
2010-09-29 02:26 graham Note Added: 0000613
2010-09-29 02:26 graham Status confirmed => resolved
2010-09-29 02:26 graham Resolution open => fixed
2010-09-29 02:26 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker