Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001009Core InformPhrases and functional programmingpublic2012-09-27 14:152014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001009: Problem message wording implies that ``decide yes'' and ``decide no'' do not decide on a value.
DescriptionThe problem message provoked by the attached source is

- - - -
Problem. The line 'decide no' seems to be a way that the phrase you're defining can come to an end, with a phrase to make a decision, but it should always end up with a phrase to decide a value.
 See the manual: 18.11 > Named outcomes
- - - -

which reads oddly because Inform acknowledges truth states as values elsewhere. Also, the link points to WI 18.11 rather than 11.16.
Minimal Source Text To Reproduce
There is a room.
To decide what number is foo:
	decide no.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0001853)
zarf (developer)
2012-09-29 11:47

"decide on true" produces the correct error ("...this was the wrong kind of value: a truth state rather than a number.") This makes sense, since "yes" and "no" are not truth values per se.

- Issue History
Date Modified Username Field Change
2012-09-27 14:15 EmacsUser New Issue
2012-09-27 14:17 EmacsUser Description Updated View Revisions
2012-09-29 11:47 zarf Note Added: 0001853
2012-09-29 11:50 zarf Status new => confirmed
2014-01-24 02:25 graham Status confirmed => resolved
2014-01-24 02:25 graham Resolution open => fixed
2014-01-24 02:25 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker