Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001002Core InformUnderstandingpublic2012-09-17 14:182014-05-07 07:33
Reportercapmikee 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001002: Ending a command with a period causes DPMR results to be ignored
DescriptionIn the example, typing the command without a period causes the correct choice to be picked via Does the Player Mean rules. But adding a period to the end of the same command results in a disambiguation question.

Minimal Source Text To Reproduce
Test is a room.

There is a green apple in Test. It is edible.

There is a green ball in Test.

Does the player mean examining something edible: It is very likely.

test period with "x green."

test normal with "x green"
Additional InformationAs Zarf observed, the order of commands makes a difference. Quoted from forum thread at http://www.intfiction.org/forum/viewtopic.php?f=7&t=5766&sid=36a41e4196cf8d40d256bde254393597&p=41710#p41710: [^]

If you try "x green" then "x green.", you get different results. If you restart and try "x green." then "x green", both commands disambiguate.

The ordering dependency looks like bug 860 (http://inform7.com/mantis/view.php?id=860 [^]), but I don't know if that's the original problem, or just a side issue.

When I turn on extra ChooseObjects debugging, I see that one case prints "[choosing a cobj strategy: nothing interesting]"; the other prints "[choosing a cobj strategy: 0 possible second nouns]". So the appearance of extra words on the line causes it to run the DTPM rules differently? If so, the bug is in failing to recognize "." (THEN1__WD) as the end of the command.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002507)
graham (administrator)
2014-02-15 07:58

Fixed.

- Issue History
Date Modified Username Field Change
2012-09-17 14:18 capmikee New Issue
2012-09-18 09:46 EmacsUser Status new => confirmed
2014-02-15 07:58 graham Note Added: 0002507
2014-02-15 07:58 graham Status confirmed => resolved
2014-02-15 07:58 graham Resolution open => fixed
2014-02-15 07:58 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker